Instructions for the MS Labs
Basic MS3 ECU, V3.0+

1. Download TunerStudio from tunerstudio.com and install. Forget anything you
may have read about MegaTune or EasyTherm, it will not work with this ECU.
2. Decide which port you want to use (USB or serial). If you laptop has a true serial port, it
is recommended over the USB port. You don't need any drivers if you want to use the
serial port, just a serial cable. If you want to use the USB port, you need a USB cable,
type A to type B. You will need to download and install drivers for the USB port to work;
you can download them from:
http://www.ftdichip.com/Drivers/CDM/CDM%20v2.12.00%20WHQL%20Certified.exe
If the link above doesn't work for you, you can check if there's a newer driver at:
http://www.ftdichip.com/Drivers/D2XX.htm
3. All Basic MS3s currently ship with firmware version 1.4.0. Please download the .ini file
for this ECU here: https://www.mslabs.gr/Basic_MS3_140.zip
4. Make sure to save the above file on your desktop and keep a copy somewhere in case
you need it again.
5. Unzip the file on your desktop. You should now have a file named “Basic MS3 140.ini”.
This file describes the features available in this ECU to the tuning software,
TunerStudio. It is not a basemap. The basemap is already loaded inside the ECU.
6. 90-93 1.6 (US; 94-97 EU 1.6 as well) only: VERY IMPORTANT!!!!! Remove the 10A
"ST SIGN" from the engine bay fuse box. If you do not do this, the ECU will be
damaged and you will not be able to start the car!!! If you do NOT have a variable TPS,
you should also disconnect your stock TPS from the car. The ECU will not be damaged
if you don't, however it will appear as if the ECU is not working at all. You will
need to fit a variable TPS to take full advantage of this ECU. A typical and
budget TPS is the Wells type 201.
The above does not apply if your car is a factory equipped 1.8L. It ONLY applies if your
car is an original 90-97 1.6L.
7. Remove the stock ECU
8. Run a vacuum line from the intake manifold, just after the throttle body,
to the ECU (the connection is under the DB37 socket). If you don't do this,
the car may not start at all, or may shoot black smoke out of the exhaust.

9. Connect the ECU to the stock harness.
10. If you want to use a GM IAT sensor, it must now be wired in.
• On the 99-05 (Non-MSM), simply replace the stock air temperature sensor found
on the air filter box with the GM sensor. There is no polarity on the wires.
• On the MSM, the GM sensor replaces the stock air sensor that is on the TB
elbow.
• On the US 90-93 1.6L (and European 94-97 1.6L), the GM sensor replaces the
sensor that is inside the AFM (Air Flow Meter). Disconnect the AFM, and pull
back the rubber boot of the AFM's connector. You should see 7 wires on it. The
GM IAT connects to the red/green and black/green wires. No polarity.
• On the 94-97 1.8L, the GM sensor replaces the sensor that is inside the MAF
(Mass Air Flow) sensor. Disconnect the MAF, and pull back the rubber boot of
the MAF's connector. You should see 5 wires on it. The GM IAT connects to the
red/black and black/green wires. No polarity.
11. Switch the ignition to ON, do NOT start the car yet. When you switch the ignition to
ON, you should hear the fuel pump priming for 2 seconds. If you do not year the fuel
pump priming, and your car is either a 96-97 1.8L or a 99-00 (regardless of engine),
then you may need to change a jumper for the fuel pump inside the ECU. Contact us at
info@mslabs.gr for more info (make sure to tell us your ECU's serial number).
12. Connect the USB cable to the PC. Windows should detect and install your
cable.
13. After the device has been installed successfully, open the Device Manager
(Control Panel -> System -> Hardware -> Device Manager) and click "Ports" to
see which COM port it is under (usually between COM1 and COM10).
14. We are ready to connect to the ECU. Run TunerStudio.
15. Click File -> New Project
16. Give your project a name - anything will do.
17. Under ECU definition, click "Other" and browse to the .ini file you unzipped on
your desktop.
18. Click Next
19. Select:
• Oxygen Sensor: Wideband / AFR
• Temperature display: Celcius/Farenheit (whatever works for you)
• CAN_COMMANDS: Activated
• INTERNAL_LOG_FIELDS: Deactivated
• PW_4X: Deactivated
• CYL_12_16_SUPPORT: Deactivated
• PORT_STATUS: Deactivated
• OUTMSG_EDITING: Deactivated
20. Click Next
21. Under Port, select the COM port you found the USB cable to be under (ie
probably COM1 through 10)
22. Click "Test Port" - you should get "Successful". If not, try with other
ports until you succeed.
23. Click Next.
24. Select the gauge style you want
25. Click Finish
26. You should see the gauges and you should be in Online mode.

27. Calibrate your TPS (if you have a variable TPS): Tools -> Calibrate TPS.
Do not press the throttle at all, and click the top "Get Current". Then press
the throttle fully, and click the bottom "Get Current" button. The click
Close. Now when you slowly press the throttle, the "Throttle Position"
indication should slowly go from 0% to 100%.
28. 90-97 cars must ABSOLUTELY set their base timing with a timing light!!!
99-05 cars will have a 0.5-2 degrees variance - you can drive the car in
low/medium revs/loads and you shouldn't have a problem, however you should
still set the base timing.
29. A 37-way connector with pigtail is included with your ECU. There are several freehanging wires on the connector (depending on your request):
• White/Red: Fused 12V power supply for your wideband ONLY. Has an internal
6A fuse.
• Black/Yellow: Ground / Heater ground (for LC-1 widebands)
• Black/Green: Analog sensor ground.
• Yellow - Wideband input. Connect this to your wideband analog output
• Grey – Switchable tables (optional). Connect this to a ground (through an on/off
switch) to switch between VE/Ignition tables.
• Brown – Launch control input (optional). Connect to a ground (through a
momentary switch) to enable launch (when pressed).
• Brown and Green (twisted together) (optional)- Ignition output C (brown) and
ignition output D (green)
• Pink and Violet – Injection output C (pink) (optional) and injection output D
(violet) (90-93 only)
• Pink and White (twisted together) (optional) – Oil pressure input (white;
resistive), oil temperature (pink; resistive). Connect to sensor. The other end of
the sensor goes to ground.
• Violet (purple) (optional; not available on the 01-05 as the signal is already
routed through the stock harness) – VVT control solenoid (negative side) to use
on 01-05 engine swaps. The other pin of the valve needs a switched and fused
(5A) 12V power supply. The valve does not have a polarity.
• Green - Boost control output. Connect this to a boost control valve. The other
wire of the boost control valve needs to be connected to a switched and fused
12V source. A 5A fuse is recommended.
• White (optional; not available on the 99-05 as the signal is already routed
through the stock harness) – Knock input. Connect to a knock sensor.
• Pink – Digital on/off input.Connect this to a ground through an on/off switch. Can
be used to activate/deactivate features. (ie traction control, nitrous, etc).
• Orange - Free programmable output (Nitrous 2), low side. Can drive any load up
to 2A.
• Blue - Free programmable output (FIDLE), low side. Can drive any load up to
2A.

•

Complete pinout for the DB-37 connector on the rear of the ECU:
DB Pin
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37

Function
Fused 12V Out
Device ground
Analog ground
Analog wideband input
External MAP input
Spark output C
Spark output D
CANH
CANL
RPM Out
EXT_MAP Analog Input
SPARE_ADC Analog Input
PT2 On/Off Input
Tableswitch On/Off Input
-EGO2 Analog Input
-IAC1 Programmable Output
Nitrous2 Programmable Output
EBC Output
Device ground
-Nitrous_In On/Off Input
-ADC7/JS4 Analog Input
FLEX input
----ADC6/JS5 Analog Input
-DSP Knock Input
--VVT Output
FIDLE Programmable Output

Description
Convenient 12V supply for a wideband
Convenient ground supply for accessories
Ground for analog sensors
0-5V input from a wideband
For use with external MAP sensors (jumper inside)
Sequential spark output C
Sequential spark output D
CAN Bus High (+) Connection
CAN Bus Low (-) Connection
RPM (tach) signal for accessories
Spare analog (0-5V) input
Spare analog (0-5V) input
Spare digital (on/off) input (5V max!)
Spare digital (on/off) input (14V max!)
Spare analog (0-5V) input
Programmable low-side output
Programmable low-side output
Electronic boost control output
Convenient ground supply for accessories
Spare digital (on/off) input (14V max!)
Spare analog (0-5V) input
Flex fuel sensor input.

Spare analog (0-5V) input
Knock(+) sensor input. 90-97 only.

VVT(-) control output. 90-99 and MSM only.
Programmable low-side output

Note: All pins numbers are labelled on the connector if you look closely.

•

Setting the base timing:
1.
2.
3.
4.
5.
6.
7.
8.
9.

Run TunerStudio and open your project
Make sure you are in Online mode
Go to Ignition Settings -> Ignition Options/Wheel Decoder
Set "Fixed Advance" to "Fixed Timing"
Set "Timing for Fixed Advanced" to "10".
Click Burn (if running, the engine may die at this point)
Switch the ignition off and on again.
Start the car
The crank pulley on the 99-05 has two marks on it. The left mark should align
with the "10" sign just behing the pulley, while the right mark should align with
the "T" mark behind the pulley. On the 90-97, there is only one mark, which
should align with the “10” mark.
10. Go to Tools -> Trigger Wizard
11. Press the "-" and "+" buttons until both marks on the pulley are properly aligned.
On the 90-97, there is only mark, so that should align with “10”.
12. Press Burn when you are done. The engine may die.
13. Go to Ignition Settings -> Ignition Options/Wheel Decoder
14. Set "Fixed Advance" back to "Use Table" and click Burn
15. Switch the ignition off and on again - this is very important, if you don't do it, the
car may not start.
16. Start the car - the base timing is now set properly!
You are now ready to start the car and tune!

•

Basic considerations for autotune (“VE Analyze Live” aka VEAL)
◦ Don't let VEAL autotune your idle – in most cases you will get a hunting (oscillating)
idle as if your car has aggressive cams. To fix this, go to “VE Analyze Live” →
Advanced Settings ->Min RPM and set it to 1500rpm.
◦ VEAL also likes to pull fuel on the very low load areas and as a result, after
autotuning for a while the car may hesisate at very low loads. To fix this, go to “VE
Analyze Live” → Advanced Settings ->Min fuelload and set it to 30kPa.
◦ For the first 20 minutes of autotuning, set “Cell Change Resistance” to “Easy” to get
some quick results. Then set it back to “Normal”.
◦ As you go along and you are happy with the results, increase the Resistance
setting above even more.
◦ To get good results with VEAL, you need to drive VERY smoothly, as if you were
driving on ice. This means very smooth transitions on the throttle.
◦ Make sure you sweep all areas of the fuel map by setting a fuel load target (adjust
your right foot on the throttle so the fuel load remains constant while driving) then
sweep through the entire RPM range up to the rev limiter. For example, try to
achieve a constant 50% fuel load with the throttle while the RPMs increase. Repeat
as many times needed for this particular fuel load target.
◦ Start from 40% and increase the fuel load target by 10% each time, until your
maximum achievable fuel load has been reached.
◦ If you can't reach the rev limiter with very low fuel loads (ie 40%, 50%), use a lower
gear (1st, 2nd, etc).
◦ Keep your eye on the AFR gauge – if it is too lean (especially under load) step off
the throttle and add some fuel manually to the map before proceeding any further!
◦ Make sure “Update Controller” is enabled.
◦ Click “Burn” every 5 minutes to make sure you don't lose any progress if your
laptop dies of battery or crashes, etc.

